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Overview

This guide walks you through the process of exporting data from WinSchool into a format that is 
useable by Connect and/or the Data Transporter.  The exported data must be saved into a folder 
that Connect and/or the Data Transporter can access.

Occasionally school and district will have different setups for their School Information System. 
This guide will provide steps to set up the bridge for the general case.  If your setup differs from 
this guide and you are unable to set up the bridge, please consult your IT department for 
assistance.  If you are still having difficulties, please contact Discovery Support at: 
support@discoverysoftware.com.

Common Terms
Below you will find definitions for some common terms used within this document:

Connect Connect is the main program used to access the data created by the 
Bridge.  Connect generally contains a Data Transporter as one of 
its parts, and uses this Data Transporter to deliver the extracted 
data to the application that needs it. 
e.g. Principalm Connect, One Call Connect.

Data Transporter The Data Transporter is a separate program used to transport the 
data exported by the Bridge into the program which needs to 
access this data.  
e.g.  Intagrade Preview.

Bridge Acts as a bridge between your school's SIS and Connect or the 
Data Transporter.  
e.g.  data extractor, manual extract, report reader.

ODBC Stands for Open Database Connectivity.  This is a method of 
accessing a database from an application.

DSN Data Source Name.  This is the name of a specific ODBC Data 
Source.

4

mailto:support@discoverysoftware.com


Chapter 1 – Preparing the Connection to WinSchool 
Notes on Installation:
When installing the Data Extractor, on the final screen of the installation program there are three 
check boxes:

If this is the first time you have installed the Discovery Data Extractor for WinSchool, please 
ensure that the “Install OLE DB Provider” is checked.  Then follow the on-screen instructions 
for the driver installation before continuing on to the next section.
If you need help with the Driver installation please see:  Appendix A - Installing the OLE DB 
Drivers 
If you encounter problems installing please contact Discovery Support at: 
support@discoverysoftware.com
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Chapter 1.1 – Installing the Universal Access Template
For Win School to extract the data files needed by Principalm, you must first install a Universal Access Template 
(UAT) into your copy of Win School.  The UAT file is supplied as part of the Principalm package.  To install the 
UAT file:

1. Run Win School.

2. Click the Universal Access button.

3. Under the File menu on the Universal Access window, select Install Template…

4. Locate the PPEXTRCT.UAT file, normally found in 

[drive]Program Files\Discovery Software\Principalm\Win School\

and click OK.

5. The template is now installed.  You can verify this by checking if a template named “Principalm Ex-
port” exits in the template list.

Deploying the Data Extractor 
The Data Extractor should be configured to extract the school information into a shared network folder that can be 
accessed by the computer where the Data Extractor is deployed as well as the computer that will be running 
Connect.  Special attention should be paid to the network file permissions placed on this shared folder.  Only the 
person(s) using Connect at the school should have access to the shared folder.  
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Chapter 1.2 – Transferring Data from Win School
The Win School transfer is a two-step process.  First the Universal Access Template extracts the Win School data to 
FoxPro database files (dbf files), then those files are processed into the import format by Connect.

Creating FoxPro DBF Files from Win School
Earlier in this guide, you learned how to install a Universal Access Template.  Now, execute the template from Win 
School in order to extract the data.  

a. Run Win School’s Universal Access module.

b. In the Setup Menu, choose Select DBF Version and choose Version 4 from the available choices.  As of 
version 1.4, the Converter runs with both Version 3 and Version 4 formats, but some features, such as 
custom tabs, are only available in Version 4.

c. Select the Principalm Export template from the template list and click the Run button: 
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d. In the Run dialog box that appears, choose the location to extract data to by clicking the Browse… button. 
Make sure the Extract data and Clear data directory first checkboxes are checked.  Click Continue 
to proceed.

e. The Extract Log window will pop up and give you information on the progress of the extract. Depending 
on your system and the amount of data being extracted this can take some time. When the final entry in 
the log says “End Log: Principalm Extract” the extract is complete and you can close the Log window 
and the Universal Access window.
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Chapter 1.3 – Setting up the Extractor Using the User Interface

Connecting to WinSchool 

If the Discovery Data Extractor for WinSchool is not already running, run it by choosing Start-
>Programs->Principalm->WinSchool ->Discovery Data Extractor.
When first run, the Extractor requests a connection to WinSchool using this window:

Fig. 1:

You can return to this window at any time by using the File->Edit WinSchool Connection… 
menu option.
Fill in the fields as follows:

UAT Folder – enter the location of the UATDATA that was created in Chapter 1.2 – 
Transferring Data from Win School.   You may also browse for this folder using the Browse but-
ton.
Click Connect.
If you see this window:
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Then you have a problem with your data or UAT Folder.
Troubleshooting tips:  
If you encounter a problem connecting here are a few possible reasons/solutions:

● Check to make sure you are pointing to an existing database (use the Browse button to 
make sure)

●  Make sure you exported the data correctly in  Chapter 1.2 – Transferring Data from Win 
School.

● If you are still have any questions please contact Discovery Support at:
 support@discoverysoftware.com.

Setting Up a School

After you configure your WinSchool connection successfully, you are taken to the school list 
view:

Fig. 2:
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The school list view may not have any schools listed on the left side of the screen.  If this is the 
case, you just need to Add a School.  Once you have added the school then move on to 
Configuring a School for Export.

11



Add a School

To enter a school:
1. Click the Add School… button in the lower left corner of the screen.  The Edit School 

License dialog appears:
Fig. 2:

2. Enter your Discovery license key by copying the text of your license from the email you 
received and clicking “Paste Activation From Clipboard.” Alternatively, you can click 
“Get Activation Code From File” to browse for the .paf file that you received from Dis-
covery Software (it may be on your desktop). 

3. Click OK.  You will be returned to the school list view (Fig 2.), and now the newly li-
censed school will appear in the school list view to the left.

4. Follow the steps in “Configuring a School for Export” to complete the school setup.

Configuring a School for Export
To configure a school for export:

1. If your school uses a different database than you set up on the Connection screen browse 
for this location of that database in the “UAT Folder” section.
Note: If you do not browse for this folder, the “School Identification” section will not 
update with the new information.

2. Under “School Identification”:
Select the district number for your school from the School District drop-down.



Select the school number of your school from the School Number drop-down.
3. Under “Inactive Students/Staff”, choose whether to export inactive students and staff 

members.  Click on the radio button of your choice.
4. Under “Import Folder”, enter the folder that you have chosen to place this school’s export 

files in.  If this setting was already made in Connect, and Connect is on the same ma-
chine, this will already be filled in for you.

Testing the Extraction
Once you have configured a school using the above process you will want to test the extraction 
to make sure everything works.
Click “Extract School Now.” The extraction progress view will appear (see Fig. 4).
Click “Cancel” to stop the extraction at any time.

Fig 4.

Once the extraction is complete, click “OK.” You will be returned to the screen in Fig. 2, at 
which point you can add another school if you wish.

This should mean that your school is configured correctly.  Repeat this process for each of the 
schools in your district.



Removing a School
To remove a school:

1. Click the school name in the list of schools to highlight it.
2. Click the Remove School button.  The school is removed.



Chapter 2 – Manual Extraction
This section describes the process for manually transferring data from WinSchool to the Data 
Transporter or Connect.  If you wish to schedule the export process, please refer to Chapter 3 - 
Scheduling the Extractor 
Manual transfer of data from WinSchool to the Data Transporter or  Connect, involves two steps:

• Extracting data from WinSchool 

• Importing the data using Connect

Extracting Data from WinSchool 

To extract data from WinSchool, follow these steps:
1. From the Start menu choose Programs->Principalm->WinSchool ->Discovery Data 

Extractor.  This launches the Discovery Data Extractor for WinSchool.  
2. Select the school you wish to extract from the school list view.
3. Click the Extract School Now… button.  The extraction progress view will appear.
4. Click Cancel to stop the extraction at any time.
5. Once the extraction is complete,  click OK to return to the school list view.

Import Data using the Data Transporter or Connect

Follow the instructions in the correct User Guide of  the Data Transporter  or Connect to import 
the extracted data.



Exporting Photos Through WinSchool

WinSchool Data Extractor   does not currently support extraction of photos directly from the 
WinSchool database.

The extractor uses the following WinSchool fields to link students to their photos:
“Photos are identified by” setting in 
Connect

WinSchool table and field name

Student Number STUDEMO.DBF IDSTUDENT 
or
STUDEMO.DBF STDNUMBER

State ID Not in WinSchool
Photo ID Not in WinSchool
SSN No longer supported

The extractor uses the following WinSchool fields to link staff to their photos:

 “Photos are identified by” setting in 
Connect

WinSchool table and field name

Staff Number TCHDEMO.DBF IDTEACHER 
or
TCHDEMO.DBF TCHNUMBER

State ID Not in WinSchool
Photo ID Not in WinSchool
SSN No longer supported

The photos must be in .jpg format and the value found in the WinSchool table/field should be the 
file name (or the value should be referenced using a mapping file).  See the Connect User Guide 
for more information about exporting photos.



Chapter 3 - Scheduling the Extractor
The Extractor can be scheduled by selecting:

• The Schedule Extractor feature inside the Data Extractor:  This creates a district wide 
task for all schools listed in the user interface, to run each night at 1:00 AM.  Attendance 
extracts are also included in the task, but can be modified to run at separate times if 
needed.

• If you need to modify existing Scheduled Extracts see “Modifying Scheduled Tasks” be-
low.

Schedule Data Extracts Using the Schedule Extractor Feature

The Schedule Extractor feature creates a task in Windows’ Scheduled Tasks that runs weekly, 
and can be further edited and customized just like any other Windows task (see “Using Windows 
Scheduled Tasks” for details). To use the Schedule feature from inside the Discovery Data 
Extractorfor WinSchool:

1. Run  Discovery Data Extractor for WinSchool.
2. Click  “Schedule Extractor”.  
3. Enter your Windows account information in the window that appears:

Note:  Be careful when entering account information – Windows does not verify the 
information until the task is run.  If there is a mistake the task will not run, and may not 
notify you that it has not run.

4. Click OK in the Windows Account window.  After a few seconds, you will receive a 
message indicating that the task was created:

5. To view newly created tasks, open Scheduled Tasks, click Start → Programs → Ac-
cessories  → System Tools  → Scheduled Tasks.  The task will be labeled Discovery 



WinSchool District Extract.  You can double-click the task to modify it further if you 
desire.
Troubleshooting Tips:  If your task is not running on schedule, open the Scheduled 
Tasks window and scroll to the right.  If the Status column indicates that the account in-
formation is wrong, you will need to re-enter it on the Task pane inside the Scheduled 
Task property window.
You may need to ensure that the Windows user account has sufficient rights to run this 
task.

Important scheduling notes:
Be sure to leave the computer you use to schedule tasks on and logged in to ensure the scheduled 
tasks are run. You may wish to discuss this with your IT department to ensure this complies with 
your computer-use policies.
If the data extractor encounters any errors while extracting during a scheduled task, an error log 
may open up in a text editor. If you notice an error log, check the last few entries in the log file 
for more information. If you cannot determine the cause please contact Discovery Support – 
support@discoverysoftware.com for further assistance.  

Modifying Scheduled Tasks

The “Schedule Extractor” feature will schedule all of the schools that you have currently set up in 
the Data Extractor.  Only one scheduled task is created.  This task runs a batch file, which runs 
each school extraction separately, and in order.
The batch file that is scheduled to run can be found:
WindowsXP/2000:
  C:\Documents and Settings\[user]\Application  
Data\Principalm\WinSchool\DistrictScheduling.bat
Windows Vista:
  C:\Users\[user]\AppData\Roaming\Principalm\WinSchool\DistrictScheduling.bat
 Where [user] is your windows user name.
This batch file is a text file that contains the command line code for running the program.  See 
Appendix C – Advanced Setup for more information on how to modify this code.

Canceling Scheduled Tasks

1. Click Start > Programs (or All Programs) > Accessories > System Tools > Scheduled 
Tasks.

2. Right-click the task you wish to cancel.
3. Click “Delete.”
4. Click “Yes” to confirm cancellation.

mailto:support@discoverysoftware.com


Chapter 4 – Customizing Export

What Can I Customize?
As we receive user feedback on fields that they wish to add we will continue to expand the Discovery Data Extractor 
for WinSchool.  If you have suggestions on fields that exist in WinSchool that you would like to see added to the 
Data Extractor; or any other features, please do not hesitate to contact us at support@discoverysoftware.com.

Attendance Codes: AttCodes.pef
In the AttCodes.pef file you can see Attendance Codes and their associated values (example below).

When the Data Extractor runs for the first time it generates these values based on the information available in the 
database.

This allows for customization of the Attendance codes.

• If you wish to add new Attendance Values:

o Ensure that no blank lines exist between records.

o Enter the new code on a new line at the end of the record.

o Use tabs to separate the columns.

o Enter the Description for this Attendance Code.

o Enter ‘Y’ or ‘N’ indicating whether this value is Excused or not.

o Enter a value between 0 and 1 indicating the number of Absents or Tardies this code represents.

o For new Attendance Codes to appear in Principalm, These Attendance Codes must exist in 
the ATT_BOTTOMLINE table, along with student data.

• If you wish change Attendance Values:

o Modify the Description for the Attendance Code you wish to change.

o Enter ‘Y’ or ‘N’ indicating whether this value is Excused or not.

o Enter a value between 0 and 1 indicating the number of Absents or Tardies this code represents.

Code Description Excu
sed

Absent 
Value

Tardy 
Value

EA Excused Period Absence Y 1 0

EV Vacation/Out of Town Y 1 0

T Tardy to Class Y 0 1

TE Tardy Excused Y 0 1

TU Tardy Unexcused N 0 1

U Unexcused Absence N 1 0

UA Unexcused Absence N 1 0

• On subsequent data extractions, this AttCodes.pef file will no longer be generated (unless this file 
does not exist).  This means that if the database is updated with new information in the ATT_CODE table, 
this information may not be displayed on your PDA.
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• If you wish to have the Data Extractor extract up to date information, follow these steps:

o Browse to your import folder as specified in the Data Extractor.

o Find the AttCodes.pef file:

o If you have not modified the AttCodes.pef file by hand, delete AttCodes.pef.

o If you wish to keep some of the data that you have changed, rename the AttCodes.pef file to 
AttCodes.old.

• Run the Data Extractor.

• To add your old data:

o Open both the AttCodes.pef file and the AttCodes.old file.

o Copy any entries from the AttCodes.old file over existing entries in the AttCodes.pef file.

o Save the AttCodes.pef file and you are ready to go. 

Chapter 5 – Uninstall
To uninstall the Discovery Data Extractor for WinSchool from your system, follow these steps:

1. Click Start > Control Panel > Add/Remove Programs.

2. Select “Discovery Data Extractor for WinSchool.”
3. Click “Remove” to uninstall the program.



Appendix A – Setting Up the  OLE DB Provider for Visual FoxPro
If you have checked the “Install OLE DBC Driver” check-box on the Data Extractor install 
screen, this installer should begin automatically.  Otherwise, you may need to browse for the file. 
It will be located in the WinSchool Data Extractor installation directory.   Browse to this file (the 
volume may differ):

C:\Program Files\Discovery Software\Principalm\PPWinSchool\vfpoledb.exe
1. Run this program (double click on it), or wait for the window to pop-up if you 

checked the check-box

2. Click Next.
3. Agree to the Terms of the Agreement (after reading them of course).



4. Click Next.

5. Click Next.

6. Ensure the Destination folder is correct.  Click Next.



7. Choose Minimal or Typical, Typical is recommended.

8. Click Install. 



9. Click Finish.
The OLE DB Drivers are now installed and ready to use.  If you experience any difficulties, 
please contact Discovery Support: support@discoverysoftware.com .
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Appendix B – Help Logs (Advanced)

There are some logs generated by the Data Extractor. If you have a support issue, these logs will 
be very helpful for our support department. They contain no sensitive information.
You can access these logs by following the steps below:

WinSchoolExtractLog.txt
This file is only created once you have begun the Extraction.  It is located in the Import Folder 
you set up when configuring your school. You can open this file with any text editor program.

WinSchoolRunLog.txt
This file is located in different areas depending on your Operating System:

WindowsXP/2000: located at: C:\Documents and Settings\[user]\Application Data\Principalm\
WinSchool\WinSchoolRunLog.txt. 

Windows Vista: located at: C:\Users\
[user]\AppData\Roaming\Principalm\WinSchool\WinSchoolRunLog.txt.

Replace [user] with your Windows user name.
If there was an error or you have closed the Data Extractor, this file will also be located in the 
Import Folder.



Appendix C – Advanced Setup

This section is intended for advanced users.  If you do not understand command line processing, please contact your 
IT department or follow the set up method described in Chapter 1.1 – Setting up the Extractor Using the User 
Interface.

We now allow command line functionality to set up single and multiple extractions without using the User Interface.

This is very useful for Districts as it allows you to set up multiple schools in a short amount of time.

It is suggested that you set up the extractor once using the User Interface to ensure that the extraction works 
correctly.  

Command Line Quick Start
Use the following command as a guide to set up and run your Data Extractor quickly.

[Path to PPWinSchool.exe]\PPWinSchool.exe –d”[DSN Name] –c[district number] –n[school number] –
i”[inactivedate] –l”[path to license file]” –p”[importpath]” –a”ad”
[Path to PPWinSchool.exe] is the full path to the location of the executable file, PPWinSchool.exe.

[DSN Name] is the name of the ODBC connection that you set up in Chapter 1.

[districtnumber] is the district  number of the school you wish to export.

[schoolnumber] is the school or building number of the school you wish to export.

[inactivedate] supply this value if you wish to import inactive staff and students.  Any students/staff 
made inactive after this date will be included in the import.  Do not use the –i flag if you 
do not want inactive staff/students.  This value should be in the format YYYYMMDD.

[path to license file] is the full path to the .paf file

[import path] is the path of the import directory, where you wish the files to go.

If you do not understand any of the above parameters, please see the Parameters Section below.

Command Line Usage

The WinSchool Data Extractor can be run on the command line, or through a batch file.

This is accomplished the following ways:

Command Line:
First you need to locate the executable.

It will generally be located in the following location unless you changed the destination directory during 
installation: 

"C:\Program Files\Discovery Software\Principalm\PPWinSchool\PPWinSchool.exe"

You can run this directly in Windows by choosing Start->Run:

And typing in the following:

C:\Program Files\Discovery Software\Principalm\WinSchool\PPWinSchool.exe <parameters>

Where <parameters> should be replaced by the required parameters listed in the Parameters Section.

Batch File:
A Batch file works in very much the same way as the command line above.



First on your desktop right click and choose New->Text Document.

This will create a text document on your desktop, normally called “New Text Document.txt”

Next double click on this file to open it for editing.

Type the following line:

C:\Program Files\Discovery Software\Principalm\PPWinSchool\PPWinSchool.exe <parameters>

Where <parameters> should be replaced by the required parameters listed in the Parameters Section.

Save the file as WinSchool.bat and close the program you are editing it in (typically Notepad).

Notes on Use

The Data Extractor works on a per license basis; this means that you need one license (.paf file) for every school that 
will be using the Data Extractor.  Connect shares this license, so if you are importing Data for one school you only 
need one license.



Appendix D – Parameters

Running the Discovery Data Extractor from the command line is very simple once you understand what elements 
are required.

District Number: -c The District Number is the number of the district for the school you wish to export. 

School Number: -n The School Number is the number of the school you wish to export. 

Inactive:  -i  The Inactive setting indicates whether or not you want to extract inactive students and 
teachers.  This should be entered as yes for all inactive staff and students, or in the 
format YYMMDD.  

School License:  -l  The School License is the full path of the licensee file supplied by Discovery Software. 
This file will be in a .paf format.  If you do not have this file, please contact Discovery 
Software (support@discoverysoftware.com).

Import Folder:  -p  The Import Folder is the location of the folder where you wish to extract the data to.  This 
folder will, in most cases, be the same as the Import Folder that Connect uses.  You 
need to enter the full path name.  This folder does not need to exist (the extractor will 
create it if it does not).

Master Folder:  -o  The Master Folder is the location of the UAT Data folder where you export the UAT data 
from WinSchool into.  See Chapter 1.2 – Transferring Data from Win School|outline

Export Type:  -a  The Export Type flag is used to determine which type of extract you wish to perform. 
Typically this will be set to da, for Demographics and Attendance.  

Use Clones:  -k  The Use Clones flag is used to indicate whether staff with alphanumeric teacher numbers 
are clones of staff without alphanumeric teacher numbers.  Can be true or false.  

Parameter Code Description (Matches Label in 
Extractor Window)

Example

-c District Number -c1234

-n School Number -n123

-i Inactive –i”20060102”

-l School License (Full Path) -l”c:\license.PAF”

-p Import Folder -p"c:\Import Folder"

-o Master Folder -o"c:\MasterFolder\UATDATA\"

-a Export type - include “a” for 
attendance update, “d” for 
demographics

-a"da"

Or

-a"a"

-k Use Clones -kfalse or -ktrue
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